π οΈ Post-Mortem β Incident on Click&Cert Service
Summary
On June 5, 2025, an incident impacted the Click&Cert service due to a DNS outage at one of our critical providers. Service was degraded for several hours before recovery. The issue has now been resolved and services remain stable.
Timeline (UTC+2)
05/06/2025 16:05 β Detection of a malfunction affecting the Click&Cert service. 05/06/2025 16:20 β Incident declared and investigations launched. Root cause traced to the DNS provider of one of our critical third-party vendors. 05/06/2025 18:11 β Update from the vendor: resolution efforts ongoing. 05/06/2025 21:40 β New update from the vendor: issue still unresolved. 05/06/2025 21:50 β Our monitoring indicates the service is operational again. 05/06/2025 22:15 β Incident status updated: service is up, but awaiting vendor confirmation. 05/06/2025 23:13 β Vendor reports a large-scale DDoS attack targeting their DNS provider; partial service restoration ongoing. 06/06/2025 08:45 β No further interruptions detected since 05/06/2025 21:50; services confirmed stable.
Posted Jun 06, 2025 - 11:25 CEST
Monitoring
The issue has been resolved, and we are currently monitoring the services. Investigations into the root cause are still ongoing.
A detailed post-mortem will be shared at a later time.
Posted Jun 06, 2025 - 08:45 CEST
Update
All services are now fully operational. Investigations are still ongoing to determine the root cause of the incident.
A detailed post-mortem will be shared at a later time.
Posted Jun 05, 2025 - 22:15 CEST
Identified
Incident ongoing, issue identified, resolution in progress.